Connection does not trigger open, error or close events Monodroid

Feb 5, 2014 at 7:57 PM
Some time ago I started to use WebSocket4Net on my Monodroid application, it works fine but now for some reason it stopped. After connect into the websocket the events connect, Error and Closed just doesn't trigger. I already tried many things but still don't know what is happening. Here is the code I'm using to connect on the websocket. The same websocket is already being used in a web application, so the problem is not related with the connection.
            _websocket = new WebSocket("ws://localservices.com.br/api/webchat");
            _websocket.Opened += _websocket_Opened;
            _websocket.Error += _websocket_Error;
            _websocket.Closed += _websocket_Closed;
            _websocket.MessageReceived += _websocket_MessageReceived;

            _websocket.Open();
I don't know if this could be a problem, but the last time I've tried to use the library i was using an older version of Xamarin, now I'm Currently using the version 4.10.02014