Library include problem

Mar 28, 2013 at 10:29 AM
Hello,

I got the latest version from git and used the .NET35 project file to compile the library.

I added the library as reference to my project and tried to compile my project but getting the following error:

Warning 4 The currently targeted framework ".NETFramework,Version=v4.0,Profile=Client" does not include "System.ServiceModel.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" which the referenced assembly "WebSocket4Net, Version=0.9.0.0, Culture=neutral, PublicKeyToken=eb4e154b696bf72a, processorArchitecture=MSIL" depends on. This caused the referenced assembly to not resolve. To fix this, either (1) change the targeted framework for this project, or (2) remove the referenced assembly from the project. DesktopClient

When I tried the download from this website I didn't have the problem, but I got a crash so thought of trying the latest source.

What is going wrong here?

Cheers,
Gerard
Coordinator
Apr 3, 2013 at 4:40 AM
Why you reference the .NET 3.5 Client Porfile library in a .NET 4.0 Client Profile application?
We have the .NET 4.0 Client Profile project in the source code.